Yealink

Yealink SIP-T58W IP phone Grey LCD Wi-Fi

Read reviews
SKU: SIP-T58W-C
Your price $571.03
List price $855.80 Save $284.77
GST included · AUD
New Sealed in box Australian stock Warehouses in Sydney, Melbourne, Brisbane, Adelaide and Perth Delivery only - Pickup unavailable 2-5 Business days metro delivery. Australian manufacturer Warranty

In stock — ready to ship

Estimate shipping

Enter an Australian postcode for a quick estimate.

Final shipping options and price are confirmed at checkout.

  • Local Australian stock
  • Australian manufacturer warranty
  • GST included
  • Secure checkout

Need bulk pricing for schools or councils? Request a quote via Contact Us.

7" LCD, Wi-Fi, USB 2.0, Bluetooth, 1G LAN, RJ-9, PoE, Android 9.0, 259.4x220x215 mm

Description

Free from Cord Constraint, Free from Distracting Noise

Adopting the innovative Bluetooth handset, Yealink T58W Pro pervades wireless communication by allowing the user to move around freely and conveniently.

The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

Take Smart Business Phone to the Next Level
Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

Enterprise-level Security, Provision and Management
Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.

Specifications

Features
Number of function keys 7
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Wall mountable Yes
Keypad number of keys 27
Integrated voicemail Yes
Handset type Wired handset
Product colour Grey
Hearing aid compatibility Yes
Security
Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3
Design
Product type IP Phone
Wall mountable Yes
Handset type Wired handset
Product colour Grey
Performance
Dual-Tone Multi-Frequency (DTMF) modes In-band, Out-of band, SIP info
Hearing aid compatibility Yes
Phone features
Speed dialling Yes
Redialing Yes
Phonebook capacity 1000 entries
Number of VoIP accounts 12
Message-waiting indicator (MWI) Yes
Intercom Yes
Answering machine Yes
Full duplex Yes
Do not disturb function Yes
Conference call Yes
Caller ID Yes
Call waiting Yes
Call transfer Yes
Call return Yes
Call pick up Yes
Call park Yes
Call hold Yes
Call forwarding Yes
Anonymous call rejection Yes
Anonymous call Yes
Management features
Number of function keys 7
Keypad number of keys 27
Integrated voicemail Yes
Display
Touchscreen Yes
Touchscreen type Capacitive
Display resolution 1024 x 600 pixels
Display diagonal 17.8 cm (7")
Display LCD
Camera
Front camera Yes
Rear camera Yes
Audio
Voice codecs G.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
Voice activity detection Yes
Speakerphone Yes
Noise reduction Yes
Microphone mute Yes
Comfort noise generation (CNG) Yes
Automatic gain control Yes
Adaptive jitter buffers Yes
Packet loss concealment (PLC) Yes
Video
Video call No
Network
Ethernet LAN interface type Gigabit Ethernet
Ethernet LAN data rates 1000 Mbit/s
Bluetooth Yes
Bluetooth version 4.2
Wi-Fi standards 802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)
Wi-Fi Yes
Supported network protocols IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
Security algorithms 256-bit AES, HTTPS, TLS, WPA2, WPA3
Quality of Service (QoS) support Yes
Networking standards IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Ethernet LAN Yes
Ports & interfaces
USB 2.0 ports quantity 2
RJ-9 ports quantity 2
Ethernet LAN (RJ-45) ports 2
Power
Power over Ethernet (PoE) Yes
Operational conditions
Operating temperature (T-T) 0 - 40 °C
Operating relative humidity (H-H) 10 - 95%
Weight & dimensions
Width 259.4 mm
Depth 220 mm
Height 215 mm
Weight 8.86 kg
Package width 324 mm
Package depth 293 mm
Package height 128 mm
Package weight 9.56 kg
Packaging content
Number of handles included 1 pc(s)
Brand
Yealink
SKU
SIP-T58W-C

You may also like